
Deploying and Configuring 
Enterprise Connect 2.0



Deploying and Configuring Enterprise Connect 2.0

Contents

Section 1. Install Software ...................................................................................... 3

Section 2. Create a basic settings profile for Enterprise Connect ........................ 4

Section 3. An overview of Enterprise Connect ...................................................... 8

Section 4: Live Password Testing and Password Sync ....................................... 12

Section 5: Password Requirement Banner .......................................................... 16

Section 6: Password Change Script ..................................................................... 21

Section 7: Audit and Connection Complete Scripts ............................................ 26

Section 8: Branding ............................................................................................... 32

Section 9: Create a Privacy Preferences Policy Control Profile .......................... 35

Section 10: Package Scripts for Jamf Pro Deployment ...................................... 38

Section 11: Deploy Enterprise Connect with Jamf Pro ....................................... 40

Section 12: Test the Enterprise Connect Deployment from Jamf Pro ................ 50



3

Deploying and Configuring Enterprise Connect 2.0

NOTE: This guide uses Jamf Pro version 10.12 as the MDM server.
 

Requirements
1.  Enterprise Connect 2.0.2 or later provided by Apple.
2.  Profile Creator 0.3.0 or later.  Get it here:  https://github.com/erikberglund/ProfileCreator/releases
3.  PPPC Utility 10.01 or later.  Get it here: https://github.com/jamf/PPPC-Utility/releases
4.  Jamf Composer - This guide uses version 10.12.
5.  Access to a Jamf Pro server. This guide uses a cloud hosted server.

Section 1. Install Software

In this section we install the applications that will be used in this guide.

1. Double-click the Enterprise Connect installer and accept all the default prompts. Enter your admin credentials 
when prompted.

2. To install ProfileCreator, open the DMG and drag the ProfileCreator application to the Applications folder.

3. To install PPPC Utility, drag the PPPC Utility application from the Downloads folder to the Applications folder.
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Section 2. Create a basic settings profile for Enterprise Connect

In this section we create and install a basic configuration profile that will set the Active Directory Domain and 
mount a network home directory.

1. Open ProfileCreator located in the Applications folder. Approve any security messages if prompted. At first we 
will save the configuration profile locally so we can install it without Mobile Device Management for testing. 
After you discover which settings work for your desired workflow at your organization, you can export the 
configuration profile for use with Jamf Pro or another MDM.

2. Go to the ProfileCreator menu and choose Preferences.

3. In the toolbar, click Profile Defaults, then enter your Organization Name and Organization Identifier. Click the 
red button in the upper-left corner when done.

4. Click the Add button (+).

Click to 
close the 
window
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5. Enter the following in the General Section:

A. Name: Enterprise Connect Settings
B. Payload Description: Enterprise Connect Settings
C. Organization - [This should already be populated]
D. Payload Scope: Set to System

6. Follow these steps:

A. Select the Application icon. 
B. Select Enterprise Connect.
C. Next to Active Directory Relam, click Add (+), and enter your realm.
D. In the upper-right corner, click Add to add these Enterprise Connect settings to the configuration profile.

A

A

B

B

C

C

D

D
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7. Confirm your Enterprise Connect settings look like the figure below.

8. Follow these steps:

A. Click the Shares tab.
B. Next to Mount Network Home Directory, click Add (+).
C. Select the checkbox to enable this option.

A

B

C
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9. From the File menu, choose Save. 10. Choose File > Export.

12. Double-click the configuration profile to install it. Enter your admin credentials when prompted and accept all 
installation prompts.

11. Follow these steps:

A. In the Save As field, enter Enterprise Connect Settings.
B. Set the Desktop as the location to save the file in.
C. Click the Payload Content Style menu and choose MCX.
D. Click Save.

Note: In step C we export this to a .mobileconfig file with the MCX format instead of the Profile format. For 
the first portion of this guide we’ll manually install the .mobileconfig file and it doesn’t matter which format we 
use, but eventually you’ll use the MCX format to upload to your MDM. Jamf Pro will strip an unsigned profile 
when you upload it. If you have a code signing certificate, you can sign the profile and save it. When you 
upload it to Jamf Pro, it will not strip the signed profile.

A

B

C

D



8

Deploying and Configuring Enterprise Connect 2.0

Section 3. An overview of Enterprise Connect

In this section we launch Enterprise Connect and go over the interface and menu bar item.

1. Launch Enterprise Connect located in the Applications folder.

2. Notice the Active Directory Domain is prepopulated and unavailable for editing. This is because when we 
configure a setting in a configuration profile, the user interface does not allow a user to modify the setting. 
Click the arrow in the bottom-left corner to display more settings.

4. During sign in you will be presented with the message below. This is because we used the Enterprise 
Connect configuration profile to configure Enterprise Connect to mount the user network home directory. 
The message is displayed only one time per user per server; it will not be displayed the next time the user 
connects to this server. Click Connect at this message.

3. Follow these steps:

A. Enter a username.
B. Enter a password.
C. Click Sign In.

A
B

C
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5. Your network home directory will be mounted.

6. Enterprise Connect is now signed in. 

A. Click the General tab to configure more items. 
B. This will hide or show the Enterprise Connect menu bar status item in the menu bar.
C. If you want to keep your local Mac login password in sync with your Active Directory, enable this  

checkbox.
D. This will be enabled if you enable the “Enable Smart Card Mode” option in the Enterprise Connect 

configuration profile.
E. Configure the number of days to wait to alert the user before their Active Directory password expires.  

NOTE: You can configure these options in the Enterprise Connect configuration profile; options that you 
configure in the configuration profile will be dimmed for the user.

A

B

C

D

E
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7. Click the Shares tab to configure more items.

A. Mount the user’s Active Directory home directory on the Mac.
B. Mount any additional shares that are needed on the Mac.

NOTE: “Mount my network home directory” is selected and dimmed. This is because we set this in the 
Enterprise Connect configuration profile.

8. Click the Status tab. This will show you the password status of the currently logged-in user. In the figure 
below, this user’s password does not expire, which is why it shows Not Available. If this was a user whose 
password was set to expire, it would show more information.

A

B



11

Deploying and Configuring Enterprise Connect 2.0

9. Notice the key icon in the menu bar. This is the Enterprise Connect menu bar status icon.

NOTE: In version 2.0 of Enterprise Connect, you can hide the menu bar status icon.

10. If the Enterprise Connect menu bar status item is dark black, this indicates that Enterprise Connect is 
connected. If the Enterprise Connect menu bar status item is gray, Enterprise Connect is not connected.

11. Click the Enterprise Connect menu bar status item in the menu bar. It displays information for the signed-
in user and their password expiration status. It also allows you to choose Reconnect, Open Enterprise 
Connect Client, and Change Password.
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Section 4: Live Password Testing and Password Sync

In this section we configure live password testing and syncing the local Mac account password with the Active 
Directory account password.

1. Open ProfileCreator.

2. Double-click the Enterprise Connect Settings profile we created in section 2 of this guide.

3. Follow these steps:

A. Click the Password tab.
B. Click Add (+) next to Sync Local Password then select the checkbox to enable the option. 
C. Click Add (+) next to Password Required Complexity then select the checkbox to enable the option.
D. Click Add (+) next to Password Required Complexity Disable Unicode then select the checkbox to 

enable the option.
E. Next to Password Required Length option, click Add (+) then enter an appropriate number. This guide 

uses 8 as an example. 

B

C

D

E

A
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4. Choose File > Save.

5. Choose File > Export.

6. Follow these steps:

A. In the Save As field, confirm the file name is Enterprise Connect Settings.
B. Confirm that the Desktop is the location to save the file in.
C. Click the Payload Content Style menu and choose MCX.
D. Click Save. When you are asked if you want to replace the existing file, click Replace.

A

B

C

D
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7. Double-click the configuration profile to install it. Enter your admin credentials when prompted and accept all 
installation and overwrite prompts.

8. Click the Enterprise Connect menu bar status item and then choose Change Password.

9. Enter your old Password.

10. Enter your new password. Notice the live password testing pop-up changes the status indicators to green 
when all the password requirements are met.
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11. Enter your new password in the Verify field, then click Change Password.

12. Enterprise Connect prompts you to sync your local Mac login password with your Active Directory 
password. Enter your current Mac login password, then click OK.

13. Passwords are now in sync. Click Ok.

NOTE: If a user clicks Cancel at the above message, they will need to confirm they don’t want to sync their 
passwords.
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Section 5: Password Requirement Banner

In this section we go over creating a banner to display the password requirements to users. If your organization 
uses a non-standard password complexity, so you can’t use live password testing, you can configure Enterprise 
Connect to display a document with your organization’s password requirements as they enter their new 
password. 

1. Open Text Edit and create a password requirement banner. It can contain graphics.  
The format must be rtf or rtfd (Rich Text Document or Rich Text Document with Attachments).

2. Save the password banner in the same location on all Mac computers that will use it. For this guide, we save 
the banner in /Library/Security/PasswordBanner.rtfd

3. Open ProfileCreator.
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4. Double-click the Enterprise Connect Settings profile.

5. Follow these steps:

A. Click the Password tab.
B. Next to Password Required Complexity, click Remove (X) to remove this option.
C. Next to Password Required Complexity Disable Unicode, click Remove (X) to remove this option.
D. Next to Password Change Message Path, click Add (+) to enable this option.
E. Enter the path to the password banner (for this guide it is /Library/Security/PasswordBanner.rtfd).

A

B

C

D

E
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6. Choose File > Save.

7. Choose File > Export.

8. Follow these steps:

A. In the Save As field, confirm the file name is Enterprise Connect Settings.
B. Confirm that the Desktop is the location to save the file in.
C. Click the Payload Content Style menu and choose MCX.
D. Click Save. When you are asked if you want to replace the existing file, click Replace.

A

B

C

D
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9. Double-click the configuration profile to install it. Enter your admin credentials when prompted and accept all 
installation and overwrite prompts.

10. Click the Enterprise Connect menu bar status item and then choose Change Password.

11. Enter your old password.

12. Enter your new password. The Password Banner will appear.
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13. Enter your new password in the Verify field, then click Change Password.

14. You will be prompted to sync your local Mac login password with your Active Directory password. Enter your 
current Mac login password, then click OK.

15. Passwords are now in sync. Click Ok.
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Section 6: Password Change Script

In this section, we create a script to delete keychain entries during a password change.

1. Enterprise Connect includes a “Sample” scripts directory. We will use the PasswordChangeSample.sh script 
for this lesson.

2. Navigate to /Library/Scripts and create a directory called EnterpriseConnect. To place a copy of the 
PasswordChangeSample.sh in the EnterpriseConnect directory, Option-drag the PasswordChangeSample.sh 
file from its original folder to the /Library/Scripts/EnterpriseConnect folder.

3. In this step, modify the ownership and permissions for the script. Enterprise Connect will not execute a script 
if it doesn’t have correct permissions. Only the root user should have permissions to modify the script, and 
the user running Enterprise Connect should have permissions to read and execute, but not modify, the script.

    Open Terminal. Run the following commands and enter your password if prompted:

 sudo chown -R root:wheel /Library/Scripts/EnterpriseConnect

 sudo chmod -R 755 /Library/Scripts/EnterpriseConnect/PasswordChangeSample.sh

4. Open ProfileCreator.
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5. Double-click the Enterprise Connect Settings profile.

6. Follow these steps:

A. Click the Password tab.
B. Next to Password Required Complexity, Add (+) to enable this option.
C. Next to Password Required Complexity Disable Unicode, Add (+) to enable this option.
D. Next to Password Change Message Path, click Remove (X).
E. Next to Run Password Change Script on Local Password Sync, click Add (+) to enable this option. 
F. In the Password Change Script Path field enter the appropriate value. This guide uses the following 

example path: /Library/Scripts/EnterpriseConnect/PasswordChangeSample.sh.

A

B

C

D

E

F
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7. Choose File > Save.

8. Choose File > Export.

9. Follow these steps:

A. In the Save As field, confirm the file name is Enterprise Connect Settings.
B. Confirm that the Desktop is the location to save the file in.
C. Click the Payload Content Style menu and choose MCX.
D. Click Save. When you are asked if you want to replace the existing file, click Replace.

A

B

C

D



24

Deploying and Configuring Enterprise Connect 2.0

10. Double-click the configuration profile to install it. Enter your admin credentials when prompted and accept all 
installation and overwrite prompts.

11. Open Keychain Access located in /Applications/Utilities. This guide illustrates a pre-existing Exchange 
keychain item that stores the Exchange credentials for the currently logged-in user. This guide will 
demonstrate that when you change your password, the PasswordChangeSample.sh script removes your 
Exchange keychain item.

NOTE: The PasswordChangeSample.sh script can remove Exchange, Lync, and 802.1X keychain items. 
You can also edit this script to fit your needs.

12. Click the Enterprise Connect menu bar status item and then choose Change Password.

13. Enter your old password.
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14. Enter your new password then click Change Password. After enter a valid old password and new password 
then click Change Password, the  PasswordChangeSample.sh script will run and remove the Exchange 
keychain item.

15. Open Keychain Access. Confirm that the Exchange keychain item has been removed. 

16. Quit Keychain Access.
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Section 7: Audit and Connection Complete Scripts

In this section we go over creating audit and connection complete scripts.

NOTE: There are sample Audit and Connection Completed scripts in the Enterprise Connect 2.0.2 manual  
on pages 26 -28. 

1. Create an audit script. Use the sample script below. This script will check if Filevault is enabled. If not, it will 
deny connection. Save it to your Desktop as audit.sh.

 #!/bin/sh
 # Sample Enterprise Connect audit script
 # Check if FileVault is on.
 fdesetup status | grep ‘FileVault is On’
 if [ $? -ne 0 ]; then
 # Write a message to the system log and exit with a non-zero status.
 logger -t “ECAudit” “Audit script failed - FileVault is not enabled”
 exit 1
	 fi
 # If we got here, the system passed the audit, so exit with a 0 (success)
 # exit code
 exit 0

2. Create a connected completed script. Use the sample script below. This script will display a notification upon 
a successful connection. Save it to your Desktop as connectionCompleted.sh.

 #!/bin/sh
 # Sample Enterprise Connect connection completed script
	 /usr/bin/osascript	-e	‘display	notification	“Enterprise	Connect	AD	Connection	Was	 
 Successful” with title “Enterprise Connect”’
 exit 0

3. Use this step to move the scripts to /Library/Scripts/EnterpriseConnect then change ownership and 
permissions so they will work when used with Enterprise Connect. Open Terminal, then run the commands 
below. 

 NOTE: Replace ladmin with the name of your user account.

sudo	mv	/Users/ladmin/Desktop/audit.sh	/Library/Scripts/EnterpriseConnect/

sudo	mv	/Users/ladmin/Desktop/connectionCompleted.sh	/Library/Scripts/
EnterpriseConnect/

sudo chown root:wheel /Library/Scripts/EnterpriseConnect/audit.sh

sudo chown root:wheel /Library/Scripts/EnterpriseConnect/connectionCompleted.sh

sudo chmod 755 /Library/Scripts/EnterpriseConnect/audit.sh

sudo chmod 755 /Library/Scripts/EnterpriseConnect/connectionCompleted.sh

4. Open ProfileCreator.
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5. Double-click the Enterprise Connect Settings profile.

6. Follow these steps:

A. Click the Connection tab.
B. Next to Connection Completed Script Path, click Add (+) to enable this option, then enter 

an appropriate path. This guide uses the following example path: /Library/Scripts/
EnterpriseConnect/connectionCompleted.sh.

C. Next to Run Audit Script, click Add (+) then select the checkbox to enable this option.
D. Next to Audit Script Path, click Add (+) then enter an appropriate path. This guide uses the following 

example path: /Library/Scripts/EnterpriseConnect/audit.sh.

A

B

C

D
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7. Choose File > Save.

8. Choose File > Export.

9. Follow these steps:

A. In the Save As field, confirm the file name is Enterprise Connect Settings.
B. Confirm that the Desktop is the location to save the file in.
C. Click the Payload Content Style menu and choose MCX.
D. Click Save. When you are asked if you want to replace the existing file, click Replace.

A

B

C

D
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10. Double-click the configuration profile to install it. Enter your admin credentials when prompted and accept all 
installation and overwrite prompts.

11. Click the Enterprise Connect menu bar status item and choose Reconnect.

13. Enable FileVault on the Mac. Open System Preferences, which is located in the Dock.

14. Click Security & Privacy.

12. The audit script will fail because Filevault is NOT enabled on the Mac used for this guide. You will be greeted 
with the message below. Click OK.
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15. Follow these steps:

A. Click the FileVault tab.
B. In the lower-left corner, click the lock then authenticate with your admin credentials.
C. Click Turn On FileVault.

16. Select “Create a recovery key and do not use my iCloud account” then click Continue.

17. Take note of your recovery key (which is partially obscured in the following figure). Click Continue.

A

B

C
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18. Once you see an Encrypting progress bar (or for Mac computers with the Apple T2 Security Chip, the status 
of Encrypted will be immediate), quit System Preferences.

20. Now that FileVault is enabled, the audit script will pass and the connection completed script will run. You will 
see the notification message below.

19. Click the Enterprise Connect menu bar status item and choose Reconnect.
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Section 8: Branding

In this section we go over branding Enterprise Connect Notifications. In Enterprise Connect 2.0 you can 
customize the icon used in notifications, as well as the text used in the label for the “Username” field. 

1. Use a logo of your choosing. Make sure the logo is 512 x 512 pixels in PNG, GIF, or JPG format for best 
results. This guide uses the sample path: /Library/Desktop\ Pictures/HCS.png.

2. Open ProfileCreator.

3. Double-click the Enterprise Connect Settings profile.

4. Follow these steps:

A. Click the General tab.
B. Next to Organization Username Label click Add (+) to enable this option, then enter: UserID.
C. Next to Organization Logo click Add (+) to enable this option, then enter an appropriate value. This 

guide uses the example path: /Library/Desktop\ Pictures/HCS.png.

A

B

C
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5. Choose File > Save.

6. Choose File > Export.

7. Follow these steps:

A. In the Save As field, confirm the file name is Enterprise Connect Settings.
B. Confirm that the Desktop is the location to save the file in.
C. Click the Payload Content Style menu and choose MCX.
D. Click Save. When you are asked if you want to replace the existing file, click Replace.

A

B

C

D
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8. Double-click the configuration profile to install it. Enter your admin credentials when prompted and accept all 
installation and overwrite prompts.

9. The quickest way to force a notification from Enterprise Connect is to login as a user that has never logged 
into Enterprise Connect. If you have an additional user on your Mac, log in as a different user. Otherwise open 
Systerm Preferences, use Users & Groups preferences to create a new user, then log in with this new user. 
You will be greeted with the message below. Click Set Up.

10. The Username field now appears as UserID.

11. Log out, then log in with the user account you used at the start of this guide.
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Section 9: Create a Privacy Preferences Policy Control Profile

Starting with macOS Mojave 10.14, apps must ask for user consent before they can perform certain tasks that 
impact user privacy. You can grant permissions to apps in advance by using a configuration profile that contains 
a Privacy Preferences Policy Control (PPPC) payload. This way, your users will not be prompted to grant 
permissions. In this section we will create a PPPC Profile for Enterprise Connect. This PPPC Profile will allow 
Enterprise Connect access to All files, System Events, SystemUIServer, and Finder.

1. Open the PPPC Utility located in /Applications.

 

2. In the lower-left corner click Add (+).
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3. Select Enterprise Connect then click Open.

4. Follow these steps:

A. Click the All Files menu and choose Allow.
B. In the Apple Events Section, click Add (+), then select each of the following items, one at a time, and 

set them to Allow for Finder, SystemUIServer, and System Events.
C. Click Save.

A

B

C
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5. Enter the following:

A. Organization: Your organization name.
B. Payload Name: Enterprise Connect PPPC.
C. Payload Description: Enterprise Connect PPPC.
D. Click Save.

4. Follow these steps:

A. Name the file Enterprise Connect PPPC.
B. Save to the Desktop.
C. Click Save.

NOTE: We will upload this file to a Jamf Pro server in the next section. PPPC files MUST be deployed from an
MDM server. You could upload the configuration profile directly from the PPPC utility application as well, but 
we will not do that for this guide.

A

A

B

B

C

C

D
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Section 10: Package Scripts for Jamf Pro Deployment

In this section we will use Composer to package the Enterprise Connect Scripts for deployment with Jamf Pro.

1. Open Composer located in /Applications/Jamf Pro. Authenticate with your admin credentials when prompted.

2. Navigate to the /Library/Scripts folder. You will see a folder called EnterpriseConnect which contains all the 
scripts we created in this guide. 

3. Drag the EnterpriseConnect folder to the Sources section of Jamf Composer. In the Sources  
section of Composer, right-click the EnterpriseConnect package, then enter the name of it to  
EnterpriseConnect-Scripts, then press Enter to save the name change.
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4. Select the Library folder on the right side of the window and click the disclosure triangle to expand the folder 

5. Click the disclosure triangle for the Scripts folder to reveal the EnterpriseConnect folder. 

6. Select the Enterprise connect folder and make sure the Owner is root, the Group is wheel, and the 
permissions are set to 755. 

7. In the lower-right corner, click Action (looks like a gear) and choose Apply Permissions to EnterpriseConnect 
and All Enclosed Items.

8. In the Composer toolbar, click Build as PKG and save the file to the Desktop when prompted.

9. We will upload this package to the Jamf Pro server in the next section. Quit Composer.

4
5
6

7



40

Deploying and Configuring Enterprise Connect 2.0

Section 11: Deploy Enterprise Connect with Jamf Pro

In this section we will configure Jamf Pro to deploy the Enterprise Connect application, the scripts package, and 
the Enterprise Connect Settings and PPPC profiles.

1. Use your web browser to log in to your Jamf Pro server.

2. In the upper-right corner, click Settings (looks like a gear).

3. Select Computer Management, then select Packages.



41

Deploying and Configuring Enterprise Connect 2.0

4. Click New.

5. Click Choose File.

6. In the Open File dialog, select the EnterpriseConnect-Scripts.pkg file located on the Desktop then  
click Choose.
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7. If necessary, choose a Category then click Save to start the upload process.

8. Click Done. 

9. Follow steps 4 - 8 to upload the Enterprise Connect package you recently created to the Jamf Pro Server.
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10. Confirm that both packages are on your Jamf Pro Server.

11. Click the Computers icon, then select Configuration Profiles.

12. Click Upload.

13. Click Choose File. 

14. Navigate to the Enterprise Connect Settings.mobileconfig on your Desktopthen click Choose. 

15. Click Upload.
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16. Optionally, click the Category menu then choose an appropriate category, then click the Scope tab.

17. As an example, click the Scope tab, click the Target Computers menu and choose All Computers. In a 
production environment be sure to scope this to only Mac computers that are running macOS 10.14 or 
higher. Follow steps 13 - 17 to upload the Enterprise Connect PPPC.mobileconfig file located on your 
desktop. Click Save.
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18. Confirm that you have both configuration profiles on the Jamf Pro server.

19. Click the Computers icon, then select Policies.

20. Click New.
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21. Do the following:

A. In the Display Name field, enter a name. This guide uses Install Enterprise Connect 2.
B. Optionally, choose a Category.
C. Make sure Recurring Check-in is selected.
D. Click the Execution Frequency menu and choose “Once per computer.”
E. In the list of payloads, select Packages.

A

B

C

E

D
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22. Click Configure.

23. Next to your Enterprise Connect package, click Add.

24. Next to the package that you just added, click Add (+) to add another package.

25. Next to EnterpriseConnectScripts.pkg, click Add.
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26. Confirm that Jamf Pro displays both packages.

27. Select Maintenance.

28. Click Configure.



49

Deploying and Configuring Enterprise Connect 2.0

29. Confirm that the Update Inventory checkbox is selected, then click the Scope tab.

30. For this guide, select All Computers, then click Save, then click Done.

31. Confirm that Jamf Pro displays your policy with the correct name, frequency, trigger, and scope. 

31. Log out of your Jamf Pro server.
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Section 12: Test the Enterprise Connect Deployment from Jamf Pro

In this section we will test an Enterprise Connect Deployment using Jamf Pro.

1. Log in to a Mac that is enrolled in Jamf Pro but does not have Enterprise Connect installed.

2. Open Terminal. Run the following command to force a check-in with Jamf Pro.

 sudo jamf policy

 Enter your password when prompted.

3. If your test Mac already automatically checked in with your Jamf Pro server and ran the policy you just 
created, you may see a message like “No policies were found for the ‘recurring check-in’ trigger,” in Terminal. 
If your test Mac didn’t automatically run the policy yet, the ‘sudo jamf policy’ command triggers the policy to 
install Enterprise Connect in /Applications and place the EnterpriseConnect folder in /Library/Scripts. In the 
Finder, choose Go > Applications and confirm that Enterprise Connect is installed to make sure these items 
are installed.

4. In the Finder, choose Go > Go to Folder, enter /Library/Scripts, click Go, and confirm that the 
EnterpriseConnect folder is displayed. 
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7. Open Enterprise Connect and log in with your Active Directory credentials. Confirm all is working. 

This completes the guide.

5. Open System Preferences and if the Profiles preference isn’t already displayed, choose View > Profiles. 

6. Confirm that the Profiles preferences displays the two profiles that are automatically installed:  
Enterprise Connect Settings and Enterprise Connect PPPC.
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